POS & Inventory
Minimum Requirement: Mozila Firefox Browser v26.